Trouble WinXPSP2

Aus OpenVPN Wiki

Wechseln zu: Navigation, Suche

Problem bei verschlüsselten Verzeichnissen in Windows

Manchmal hat WinXP wohl Probleme, wenn man Programme in verschlüsselten Verzeichnisse installiert. Dann läuft die Installation des TAP-Devices ganz normal OHNE Fehlermeldung durch, der zugehörige Treiber dann aber nicht geladen werden kann. Bei mir lag das Problem wohl daran. Nachdem ich dann ein "normales" Verzeichnis für die Installation ausgewählt habe, waren die Probleme schlagartig weg.

Es wird keine IP Adresse zugewiesen

Unter Windows XP mit SP2 existiert ein bekannter Bug mit OpenVPN und dem integrierten DHCP Server. Unter gewissen Umständen, die leider nicht bekannt sind, nimmt der TAP Adapter des Clients die IP Adresse durch den DHCP Dienst nicht an.

Eine wirkliche Lösung gibt es dazu leider nicht, nur vereinzelte Ansätze:

  • Den TAP-Adapter umbenennen, z.B. auf "MyTAP". Dies geht nur, wenn man ihn bei der Installation nicht versteckt hat. Danach folgendes in die Config-Datei eintragen:
dev-node MyTAP
  • Eine der folgenden Zeilen in der Config eintragen:
    • ip-win32 netsh
    • ip-win32 ipapi
  • Möglicherweise helfen folgende Zeilen zusätzlich in der Client-Config:
dhcp-release
dhcp-renew
  • Manchmal blockt auch eine 3rd Party Firewall wie ZoneAlarm die DHCP Kommunikation.
  • Wurde der OpenVPN mit --server-bridge ohne Parameter gestartet, arbeitet er als DHCP Proxy, d.h. im LAN hinter dem OpenVPN-Server muss ein DHCP-Server laufen, i. d. R. ist dies ein dhcpd. Wird dieser dhcpd nach dem initialen Erstellen der Bridge nicht neu gestartet, hört er nicht auf DHCP-Anforderungen, die aus der Bridge kommen. Ein Neustart des dhcpd reicht, um zuverlässig IP-Adressen in die Bridge, und damit in das TAP-Device zu verteilen.
Persönliche Werkzeuge